Erro no lilypond book

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Erro no lilypond book

Givaldo de Cidra
Olá Pessoal,

Após atualizar o lilypond para a versão 2.12 está aparecendo o seguinte
erro:

/usr/bin/lilypond-book:32: DeprecationWarning: the md5 module is
deprecated; use hashlib instead
  import md5
Usage: lilypond-book [OPTION]... FILE

lilypond-book: error: no such option: --psfonts


Procurei na internet e algumas pessoas tiveram um erro parecido e
resolveram instalando a versão mais nova do python.
Eu olhei no meu sistema e já tenho a versão mais nova (pelo menos em
pacman).

Alguma sugestão?

--
Abraços,

GivaldoDeCidra.mus.br
"Ser e pensar sempre no OBJETIVO é o caminho para alcançar o SUCESSO"

_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Alexandre Passos
2009/1/25 Givaldo de Cidra <[hidden email]>:

> Olá Pessoal,
>
> Após atualizar o lilypond para a versão 2.12 está aparecendo o seguinte
> erro:
>
> /usr/bin/lilypond-book:32: DeprecationWarning: the md5 module is deprecated;
> use hashlib instead
>  import md5
> Usage: lilypond-book [OPTION]... FILE
>
> lilypond-book: error: no such option: --psfonts
>
>
> Procurei na internet e algumas pessoas tiveram um erro parecido e resolveram
> instalando a versão mais nova do python.
> Eu olhei no meu sistema e já tenho a versão mais nova (pelo menos em
> pacman).
>

O problema está na opção psfonts. Se vc não colocar ela, o que acontece?
--
 - Alexandre
_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Givaldo de Cidra
Alexandre Passos escreveu:

> 2009/1/25 Givaldo de Cidra <[hidden email]>:
>  
>> Olá Pessoal,
>>
>> Após atualizar o lilypond para a versão 2.12 está aparecendo o seguinte
>> erro:
>>
>> /usr/bin/lilypond-book:32: DeprecationWarning: the md5 module is deprecated;
>> use hashlib instead
>>  import md5
>> Usage: lilypond-book [OPTION]... FILE
>>
>> lilypond-book: error: no such option: --psfonts
>>
>>
>> Procurei na internet e algumas pessoas tiveram um erro parecido e resolveram
>> instalando a versão mais nova do python.
>> Eu olhei no meu sistema e já tenho a versão mais nova (pelo menos em
>> pacman).
>>
>>    
>
> O problema está na opção psfonts. Se vc não colocar ela, o que acontece?
>  
Eu já testei isso também.

Ele compila até um ponto.
Onde não acha mais o arquivo xxxx.ps


--
Abraços,

GivaldoDeCidra.mus.br
"Ser e pensar sempre no OBJETIVO é o caminho para alcançar o SUCESSO"

_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Alexandre Passos
2009/1/25 Givaldo de Cidra <[hidden email]>:
>
> Eu já testei isso também.
>
> Ele compila até um ponto.
> Onde não acha mais o arquivo xxxx.ps

Pode mostrar o erro todo e o modo como vc rodou lilypond-book?

--
 - Alexandre
_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Givaldo de Cidra
Alexandre Passos escreveu:
> 2009/1/25 Givaldo de Cidra <[hidden email]>:
>  
>> Eu já testei isso também.
>>
>> Ele compila até um ponto.
>> Onde não acha mais o arquivo xxxx.ps
>>    
>
> Pode mostrar o erro todo
lilypond-book -I ly -I ly/reg -I reg -o out arquivo.lytex ;\

/usr/bin/lilypond-book:32: DeprecationWarning: the md5 module is
deprecated; use hashlib instead
  import md5
lilypond-book (GNU LilyPond) 2.12.0
Reading arquivo.lytex...
Running latex...This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
 %&-line parsing enabled.
entering extended mode
Package Fancyhdr Warning: \headheight is too small (12.0pt):
 Make it at least 14.49998pt.
 We now make it that large for the rest of the document.
 This may cause the page layout to be inconsistent, however.

[1] (./arquivo.toc) (/home/givaldo/lib/latex/ucs/data/uni-0.def)

Package Fancyhdr Warning: \headheight is too small (14.49998pt):
 Make it at least 14.84344pt.
 We now make it that large for the rest of the document.
 This may cause the page layout to be inconsistent, however.

[2] (./arquivo.aux) )
(see the transcript file for additional information)
Output written on arquivo.dvi (2 pages, 1444 bytes).
Transcript written on arquivo.log.
cd out ;\
        dvips -o arquivo.ps -h arquivo.psfonts arquivo.dvi ;\
        cp arquivo.ps ..
This is dvips(k) 5.97 Copyright 2008 Radical Eye Software
(www.radicaleye.com)
dvips: ! Couldn't find header file arquivo.psfonts.
Note that an absolute path or a relative path with .. are denied in -R2
mode.
cp: impossível fazer stat em `arquivo.ps': Arquivo ou diretório não
encontrado
make: ** [arquivo.ps] Erro 1



> e o modo como vc rodou lilypond-book?
>  

Estou usando o comando:
 lilypond-book --psfonts -I ly -o out

o arquivo que estou compilando está no diretório ly.
esse esquema funcionava 100% até a instalação do lilypond 2.12.



--
Abraços,

GivaldoDeCidra.mus.br
"Ser e pensar sempre no OBJETIVO é o caminho para alcançar o SUCESSO"

_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Marcos di Silva-2
In reply to this post by Givaldo de Cidra
Givaldo de Cidra <[hidden email]> writes:

>> O problema está na opção psfonts. Se vc não colocar ela, o que acontece?
>>  
> Eu já testei isso também.
>
> Ele compila até um ponto.
> Onde não acha mais o arquivo xxxx.ps

Como assim?
--
Marcos di Silva
http://www.marcosdisilva.net
_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Marcos di Silva-2
In reply to this post by Givaldo de Cidra
Givaldo de Cidra <[hidden email]> writes:

> o arquivo que estou compilando está no diretório ly.
> esse esquema funcionava 100% até a instalação do lilypond 2.12.

Você vai precisar mudar muita coisa com o 2.12. Ela gera um diretório de
nome aleatório e coloca os eps (ou pdf) dos sistemas neste diretório.
--
Marcos di Silva
http://www.marcosdisilva.net
_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Givaldo de Cidra
Marcos di Silva escreveu:

> Givaldo de Cidra <[hidden email]> writes:
>
>  
>> o arquivo que estou compilando está no diretório ly.
>> esse esquema funcionava 100% até a instalação do lilypond 2.12.
>>    
>
> Você vai precisar mudar muita coisa com o 2.12. Ela gera um diretório de
> nome aleatório e coloca os eps (ou pdf) dos sistemas neste diretório.
>  

Você já fez essa mudança?

Vou pesquisar o que deve ser mudado.

--
Abraços,

GivaldoDeCidra.mus.br
"Ser e pensar sempre no OBJETIVO é o caminho para alcançar o SUCESSO"

_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Marcos di Silva-2
Givaldo de Cidra <[hidden email]> writes:

> Você já fez essa mudança?
>
> Vou pesquisar o que deve ser mudado.

Sugiro que você crie um arquivo lytex bem simples para testar. Eu não
estou encontrando que arquivo fiz com isso.
--
Marcos di Silva
http://www.marcosdisilva.net
_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Givaldo de Cidra
Marcos di Silva escreveu:

> Givaldo de Cidra <[hidden email]> writes:
>
>  
>> Você já fez essa mudança?
>>
>> Vou pesquisar o que deve ser mudado.
>>    
>
> Sugiro que você crie um arquivo lytex bem simples para testar. Eu não
> estou encontrando que arquivo fiz com isso.
>  

Rapaz..
Tentei de tudo, busquei em vários  lugares e não consegui. :-(

por hora reinstalei a versão 2.10 e tudo funcionou perfeitamente.

Em outro momento volto a enfrentar esse drama. ;-)

--
Abraços,

GivaldoDeCidra.mus.br
"Ser e pensar sempre no OBJETIVO é o caminho para alcançar o SUCESSO"

_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users
Reply | Threaded
Open this post in threaded view
|

Re: Erro no lilypond book

Givaldo de Cidra
In reply to this post by Givaldo de Cidra
Pedro Kröger escreveu:
Givaldo de Cidra [hidden email] writes:

  
cd out ;\
       dvips -o arquivo.ps -h arquivo.psfonts arquivo.dvi ;\
       cp arquivo.ps ..
This is dvips(k) 5.97 Copyright 2008 Radical Eye Software
(www.radicaleye.com)
dvips: ! Couldn't find header file arquivo.psfonts.
    

o problema é que voce esta tentando usar a versao --psfonts que a
parentemente nao existe mais. essa opcao gerava o arquivo
arquivo.psfonts que é usado pelo dvips na regra acima do seu makefile.
experimente tirar essa regra e gerar o pdf direto com 

lilypond-book --pdf yourfile.pdftex
  

Não funcionou, ainda dá o mesmo erro.

Verei isso mais tarde.
Darei notícias.

Grato,
-- 
Abraços,

GivaldoDeCidra.mus.br
"Ser e pensar sempre no OBJETIVO é o caminho para alcançar o SUCESSO"

_______________________________________________
Genos-users mailing list
[hidden email]
http://lists.genos.mus.br/mailman/listinfo/genos-users